Friday, March 21, 2025

Steps to do After Install FreeBSD


freebsd-update fetch install

Cd /var/db/portsnap

portsnap fetch

portsnap extract

# portsnap fetch
# portsnap update

Or

portsnap fetch update

Pciconf


pkg install drm-kmod

sysrc -f /etc/rc.conf kld_list+=amdgpu


Boot from livecd:-

From menu : 3

load /boot/kernel/kernel

load /boot/kernel/zfs.ko

set currdev="zfs:zroot/ROOT/default:"

boot


cd /usr/ports/graphics/gpu-firmware-amd-kmod/

make install clean

cd /usr/ports/graphics/drm-devel-kmod/

make install clean


vim /usr/local/etc/X11/xorg.conf.d/amdgpu.conf add this Code:
Section "Device"
        Identifier "Card0"
        Driver "amdgpu"
EndSection


loader.conf
fusefs_load="YES"

Rc.conf
kld_list="fusefs"


To mount linux participation:

mount -t ext2fs /dev/!!!! /mnt/!!!!

To Mount ntfs participation:
mount -t ntfs-3g /dev/!!!! /mnt/!!!!

To mount msdos:
mount -v -t msdosfs /dev/!!!! /mnt/!!!!


To handle keyboards in single user mode and at the early stages of booting process, iichid should be loaded at kernel startup. Add following lines to /boot/loader.conf in that case:
ig4_load="YES"
iicbus_load="YES"
iichid_load="YES"

Configure Xorg
Generally speaking, it is a bad idea to use static Xorg configuration for evdev devices due to dynamic unit number assignment. The simplest way to get new devices recognized by Xorg-server is to rebuild it with DEVD (since 1.20.7) or UDEV autoconfiguration backend enabled.


Static configuration is still possible. Add following snippet to a file under /usr/local/etc/X11/xorg.conf.d/


Section "InputDevice"
 Identifier "HID device"
 Driver "libinput"
 Option "Device" "/dev/input/event6"
 Option "AutoServerLayout" "true"
EndSection